AJAX fout bij inschakelen van de Add User extensie

Hulp nodig bij je installatie of kom je ergens niet uit?
Probeer phpBB3.3! Problemen lossen we samen met je op.
Plaats reactie
Gebruikersavatar
Marloes00
Berichten: 11
Lid geworden op: 23 jun 2020, 13:22

AJAX fout bij inschakelen van de Add User extensie

Bericht door Marloes00 » 24 jun 2020, 11:38

Wat is het probleem? Bij het inschakelen van de add user extensie verschijnt een "Ajax-failure": "Service unavailable"
Wanneer ontstond het probleem? Bij het activeren van de Add User extensie
Adres van je forum: https://athenakeramiek.nl/phpBB3/
Extensies op je forum: (nog) geen ingeschakelde extensies verder
Huidige stijl: standaard
phpBB versie: 3.3
Waar is je forum gehost: Webreus
Heb je onlangs iets veranderd aan je forum? Ik ben nog met de installatie en instellingen bezig
Groetjes,
Marloes

Gebruikersavatar
El torro
Berichten: 3219
Lid geworden op: 02 sep 2014, 21:28
Locatie: In het zonnige zuiden
Contacteer:

Re: AJAX fout bij inschakelen van de Add User extensie

Bericht door El torro » 24 jun 2020, 14:44

Soms vind je met de "inspect" functie van Chrome of Firefox de reden van de ajax fout.

Gebruikersavatar
Marloes00
Berichten: 11
Lid geworden op: 23 jun 2020, 13:22

Re: AJAX fout bij inschakelen van de Add User extensie

Bericht door Marloes00 » 24 jun 2020, 16:58

Dat klinkt simpel, en ik heb het geprobeerd, maar ik weet niet zo goed wat ik zoek en ook niet waar ik het moet zoeken.
Groetjes,
Marloes

Gebruikersavatar
El torro
Berichten: 3219
Lid geworden op: 02 sep 2014, 21:28
Locatie: In het zonnige zuiden
Contacteer:

Re: AJAX fout bij inschakelen van de Add User extensie

Bericht door El torro » 24 jun 2020, 18:27

Rechts klikken, kies inspect (of zoiets)
Klik op console
Schakel de extensie in en kijk naar de meldingen.

Gebruikersavatar
Marloes00
Berichten: 11
Lid geworden op: 23 jun 2020, 13:22

Re: AJAX fout bij inschakelen van de Add User extensie

Bericht door Marloes00 » 24 jun 2020, 19:44

Ja zover was ik inderdaad :D. Maar dan...?

Dit staat in de console:
Afbeelding

En in de html vind ik dit omtrent het item:
Afbeelding
Groetjes,
Marloes

Gebruikersavatar
El torro
Berichten: 3219
Lid geworden op: 02 sep 2014, 21:28
Locatie: In het zonnige zuiden
Contacteer:

Re: AJAX fout bij inschakelen van de Add User extensie

Bericht door El torro » 24 jun 2020, 20:51

Is er niets te vinden in de error logs van je server?

Gebruikersavatar
Marloes00
Berichten: 11
Lid geworden op: 23 jun 2020, 13:22

Re: AJAX fout bij inschakelen van de Add User extensie

Bericht door Marloes00 » 25 jun 2020, 17:09

Ik kan op de server geen map met foutmeldingen vinden.

Ik heb inmiddels wel gemerkt dat ik geen enkele extensie kan inschakelen in phpBB 3.3.
Steeds krijg ik een ajax-fout: "Service unavailable".

Onderstaande code krijg ik als ik javascript uitschakel. Het lijkt er dus op dat de kolom "user_msnm" mist in de database. En ik geloof dat die er inderdaad niet is. Maar hoe los ik dat op?

Code: Selecteer alles

	
Algemene fout
SQL ERROR [ mysqli ]

Unknown column 'user_msnm' in 'field list' [1054]

SQL

SELECT user_id, user_msnm FROM phpbb_users WHERE user_msnm <> '' ORDER BY user_id LIMIT 250

BACKTRACE ...
Laatst gewijzigd door Marloes00 op 26 jun 2020, 18:07, 3 keer totaal gewijzigd.
Groetjes,
Marloes

Gebruikersavatar
El torro
Berichten: 3219
Lid geworden op: 02 sep 2014, 21:28
Locatie: In het zonnige zuiden
Contacteer:

Re: AJAX fout bij inschakelen van de Add User extensie

Bericht door El torro » 25 jun 2020, 19:16

Hoe heb je het forum geinstalleerd, met de bestanden van hier of via je host?
Heb je toevallig Forceer server URL instellingen: aanstaan?

Gebruikersavatar
Marloes00
Berichten: 11
Lid geworden op: 23 jun 2020, 13:22

Re: AJAX fout bij inschakelen van de Add User extensie

Bericht door Marloes00 » 26 jun 2020, 17:01

Installeren via de server leverde een foutmelding op. Toen heb ik de bestanden hier vandaan gedownload en handmatig online gezet. Voor de zekerheid heb ik de installatie vandaag opnieuw uitgevoerd. Ik heb eerst een oudere versie geinstalleerd via de server en toen een update uitgevoerd naar 3.3. Dat leek goed te gaan. Maar het ik krijg nog steeds dezelfde foutmelding als ik probeer een extensie te activeren.
Groetjes,
Marloes

Plaats reactie