Onveilige verbinding in topic

Hulp nodig bij je installatie of kom je ergens niet uit?
Probeer phpBB3.2! Problemen lossen we samen met je op.
Plaats reactie
webferret
Berichten: 44
Lid geworden op: 27 jan 2008, 12:23

Onveilige verbinding in topic

Bericht door webferret » 22 jun 2020, 07:53

  • Onveilige verbinding in een topic
    Na verhuizing van het forum naar een andere server door mijn hostingprovider
    www.frettenvraagbaak.nl/forum http://
    ImgResize
    Pro Silver
    3.0.14
    webruimtehosting.nl
    Nee
Mijn hostingprovider heeft onlangs mijn forum verhuisd naar een nieuwe server en sindsdien heb ik een probleem.

Zodra ik inlog en niet meteen op 'Forumoverzicht' klik krijg ik een foutmelding in de browser dat de verbinding onveilig is. Melding is:'Deze site kan geen beveiligde verbinding leveren. www.frettenvraagbaak heeft een ongeldige reactie verzonden. ERR_SSL_PROTOCOL_ERROR'.
Het slotje in de adresbalk voor het adres van het forum veranderd dan in een uitroepteken. Ook verschijnt dan achter het domeinnaam :80. Dat is de poort voor HTTP en dat zou dus HTTPS moeten zijn.
Als ik de browser sluit en opnieuw naar het forum ga dan ben ik ingelogd. Ik vermoed dat dit komt door je sessie-cookie. De verbinding is dan ook ok (slotje in de adresbalk).
Ga ik naar een subforum dan gaat het nog steeds goed. Ga ik echter een topic in om het laatste bericht te lezen dan is meteen de verbinding weer onveilig (uitroepteken in de adresbalk). Ik krijg geen harde foutmelding in de browser en ik kan gewoon reageren in het topic.

Overigens gebeurd bovenstaande ook als ik als gast naar het forum ga.

Ik heb gekeken in het ACP naar de cookiesettings. Deze stond op Uitgeschakeld en ik heb deze ingeschakeld maar dat lost het probleem niet op.

Mijn hoster zegt dat het niet aan het SSL certificaat ligt maar dat het een foruminstelling moet zijn. Ik weet echter helaas niet waar ik dat zou moeten zoeken. Hij zegt dat ik iets moet doen om "SSL te forceren".

Wie oh wie kan mij helpen zodat ook de verbinding veilig is als ik in een topic zit?

Gebruikersavatar
El torro
Berichten: 3226
Lid geworden op: 02 sep 2014, 21:28
Locatie: In het zonnige zuiden
Contacteer:

Re: Onveilige verbinding in topic

Bericht door El torro » 22 jun 2020, 08:17

Ik weet niet wat je bedoelt met cookie setting uitgeschakeld?
Maar je Cookie-beveiliging: moet in ieder geval op "ingeschakeld" staan (staat nu op uitgeschakeld)
Omdat je over poort 80 begint vermoed ik dat je bij de serverinstellingen.
Server URL-instellingen

Forceer server URL instellingen:
Indien ingesteld op ja, zullen de server instellingen die hier opgegeven zijn gebruikt worden in plaats van de geautomatiseerde vastgestelde waardes.
Aan hebt staan?
Indien ja, zet dat eens uit.

webferret
Berichten: 44
Lid geworden op: 27 jan 2008, 12:23

Re: Onveilige verbinding in topic

Bericht door webferret » 22 jun 2020, 08:51

Hoi El Torro, bedankt voor je reactie!

Ik heb in het ACP onder Serverinstellingen, Forceer server URL-instellingen "Nee".

Ik heb deze op "Ja" gezet maar ik zie nog steeds een onveilige verbinding in een topic.

webferret
Berichten: 44
Lid geworden op: 27 jan 2008, 12:23

Re: Onveilige verbinding in topic

Bericht door webferret » 22 jun 2020, 08:53

Ik heb de optie eronder van http:// naar https:// gezet maar ook geen effect.

Gebruikersavatar
El torro
Berichten: 3226
Lid geworden op: 02 sep 2014, 21:28
Locatie: In het zonnige zuiden
Contacteer:

Re: Onveilige verbinding in topic

Bericht door El torro » 22 jun 2020, 09:11

Ik schreef dat hij op nee moet staan, de onveilige verbindingen komen omdat veel van je plaatjes en avatars met http beginnen maar dat heeft niets te maken met die /80 die soms in beeld zou komen, (heb ik nog niet gezien)

Ps, zou je niet snel eens gaan updaten naar 3.3.0 je loopt al 13 jaar achter met updates :o

webferret
Berichten: 44
Lid geworden op: 27 jan 2008, 12:23

Re: Onveilige verbinding in topic

Bericht door webferret » 22 jun 2020, 11:32

Ik heb het weer op Nee gezet.

Maar wat nu?

En ja, ik moet updaten maar ik heb daar helaas slechte ervaringen mee en vaak ben ik nog weken bezig om uit te zoeken wat er mis is en waardoor de boel in de soep is gelopen :oops:

Ik had een kennis die dan hielp maar die spreek ik niet meer en zelf durf ik het niet aan... :|

Gebruikersavatar
El torro
Berichten: 3226
Lid geworden op: 02 sep 2014, 21:28
Locatie: In het zonnige zuiden
Contacteer:

Re: Onveilige verbinding in topic

Bericht door El torro » 22 jun 2020, 13:00

Als ik wat rond zit te klikken op je site krijg ik geen errors hoor, alleen de onveilige plaatjes maar daar hoef je niet van wakker te liggen.

webferret
Berichten: 44
Lid geworden op: 27 jan 2008, 12:23

Re: Onveilige verbinding in topic

Bericht door webferret » 22 jun 2020, 13:26

Maar het probleem is ook dit: als ik inlog en dan niet meteen op Forumoverzicht klik maar wacht totdat ik vanzelf naar het forumoverzicht ga dat ik regelmatig de foutmelding in je browservenster krijg.

Afbeelding

Reload werkt niet...

En dit is vervelender dan af en toe een uitroepteken. Maar ook dat heb ik liever niet ;-)

Gebruikersavatar
El torro
Berichten: 3226
Lid geworden op: 02 sep 2014, 21:28
Locatie: In het zonnige zuiden
Contacteer:

Re: Onveilige verbinding in topic

Bericht door El torro » 22 jun 2020, 15:18

Welke browser gebruik je, heb je het met een andere browser ook?
Staat de tijd wel juist op je computer?
Hebben andere leden hetzelfde probleem?

toska
Berichten: 410
Lid geworden op: 18 jul 2013, 16:48
Locatie: oost-vlaanderen
Contacteer:

Re: Onveilige verbinding in topic

Bericht door toska » 22 jun 2020, 20:57

Heb daar ook even gekeken als je op forumoverzicht bent zie die pagina er goed uit, maar als je een onderwerp open dan zie je inderdaad een geel vraagteken, ook bij berichten met enkel avatars? verder lijkt me alles goed te zijn.
https://games4you.be wij bieden ook html5 en flash games aan en geven een quiz voor een waardebon en gamestoernooi voor prijzen.

webferret
Berichten: 44
Lid geworden op: 27 jan 2008, 12:23

Re: Onveilige verbinding in topic

Bericht door webferret » 23 jun 2020, 07:25

Ik heb getest met Chrome, Edge en Safari en het is overal hetzelfde. Andere leden hebben ook hetzelfde probleem.

Maar dankzij El Torro ben ik er wellicht achter wat het probleem is en ik ga dit aan mijn hostingprovider voorleggen.

Andere tips blijven welkom!

Jim
Beheerder
Beheerder
Berichten: 3894
Lid geworden op: 21 feb 2007, 14:53
Locatie: Groningen
Contacteer:

Re: Onveilige verbinding in topic

Bericht door Jim » 23 jun 2020, 09:30

toska schreef:
22 jun 2020, 20:57
Heb daar ook even gekeken als je op forumoverzicht bent zie die pagina er goed uit, maar als je een onderwerp open dan zie je inderdaad een geel vraagteken, ook bij berichten met enkel avatars? verder lijkt me alles goed te zijn.
Die avatars lijken juist het voornaamste probleem als ik er zo naar kijk. Die lijken namelijk ook geladen te worden door een externe website.

Als ik namelijk in dit topic kijk (eerste die ik aanklikte), dan zie ik dat zowel de avatar van beheerder Marian (http://www.webferrets.nl/images/other/avatar_nina.jpg) als lid Stridder (http://i.imgur.com/FZGLyUD.jpg) via http worden geladen in plaats van over https. Dat leidt dus tot een onveilige verbinding, zoals El Torro ook al aangaf.

Die andere fout die je noemt (over direct doorverwezen worden naar domain.com klinkt wel echt als serverinstellingen die niet helemaal goed staan. Zou je eens een screenshot van die pagina in je Beheerderspaneel willen nemen en ook direct (voor de zekerheid) de buffer legen op de beginpagina van het Beheerderspaneel? Dan weten we dat alle instellingen ook volledig toegepast worden.

Ik zou je overigens ook wel echt aanraden op termijn te gaan updaten naar een ondersteunde versie van phpBB. Ik zeg niet dat hier direct dit probleem vandaan komt, maar omdat er steeds nieuwere versies van PHP komen waar de host naar gaat updaten en phpBB hier door de oude versies niet meer op aansluit ga je steeds meer kleine foutjes krijgen die nergens op lijken te slaan en lastig te fixen zijn.
Jim Mossing Holsteyn - Beheerder
Documentatie | Algemene voorwaarden | Wiki

Heb je suggesties over het verbeteren van phpBB.nl of andere site-gerelateerde vragen? Stuur me een PB!

webferret
Berichten: 44
Lid geworden op: 27 jan 2008, 12:23

Re: Onveilige verbinding in topic

Bericht door webferret » 25 jun 2020, 04:27

Hoi Jim,

Je hebt gelijk; ik moet hoognodig gaan updaten. Ik heb degene benaderd die dit voorheen altijd deed en hopelijk wil hij het doen. Zoniet dan heb ik altijd het aanbod van El Torro nog.

De fouten worden inderdaad veroorzaakt door de url's die met http:// beginnen. Het rare is alleen dat dit pas in ontstaan ná een verhuizing van server bij mijn hostingprovider. Mijn contact bij die provider weet niet waarom het nu ineens anders is en stelde al voor om een query op de database te doen en alle http:// verwijzingen te wijzigen naar https:// maar dat durf ik niet aan om dat te laten doen omdat ik bang ben daardoor weer andere nieuwe problemen te krijgen.

Ik hou jullie op de hoogte! Thanks!

Gebruikersavatar
El torro
Berichten: 3226
Lid geworden op: 02 sep 2014, 21:28
Locatie: In het zonnige zuiden
Contacteer:

Re: Onveilige verbinding in topic

Bericht door El torro » 25 jun 2020, 09:23

Daarom is een test forum zo belangrijk, dan kun je prutsen wat je wilt zonder het risico je live forum te verknoeien.

Gebruikersavatar
AarClay
Berichten: 585
Lid geworden op: 10 feb 2005, 17:12

Re: Onveilige verbinding in topic

Bericht door AarClay » 06 jul 2020, 15:56

Doe dit bijvoorbeeld op een .test subdomeintje :)

Plaats reactie