Feed to Post

Hulp bij het installeren van of op zoek naar een extensie?
Plaats reactie
Maxstar27
Berichten: 6
Lid geworden op: 01 feb 2010, 15:32

Feed to Post

Bericht door Maxstar27 » 12 mar 2020, 15:56

Eergisteren heb ik deze extensie geïnstalleerd, ik heb toen handmatig de ingestelde feed verwerkt. Dit werkt allemaal goed, ook het automatisch verwerken van de feed. Alleen verschijnt het bericht dan niet met de ingestelde tekstlimiet van 500. Ook verschijnt "Lees meer" link bij het automatisch toevoegen als "Read more". Zie de topics van 11 en 12 maart in vergelijking met de eerdere topics die ik handmatig heb verwerkt.

Zowel het account-ID heeft Nederlands als standaardtaal als het forum zelf.

Gebruikersavatar
Ger
Moderator-team
Moderator-team
Berichten: 4856
Lid geworden op: 03 jan 2006, 22:23
Locatie: 192.68.1.100
Contacteer:

Re: Feed to Post

Bericht door Ger » 12 mar 2020, 20:53

Wat is de URL van de feed?

Maxstar27
Berichten: 6
Lid geworden op: 01 feb 2010, 15:32

Re: Feed to Post

Bericht door Maxstar27 » 13 mar 2020, 07:23

Hallo Ger,

Dit is de URL van de feed: https://www.pcwebplus.nl/feed/

Gebruikersavatar
Ger
Moderator-team
Moderator-team
Berichten: 4856
Lid geworden op: 03 jan 2006, 22:23
Locatie: 192.68.1.100
Contacteer:

Re: Feed to Post

Bericht door Ger » 13 mar 2020, 11:13

Ik krijg netjes de volledige feed inhoud te zien. Limiteer ik op 500 tekens, dan zie ik dit:
Ger schreef:
12 mar 2020, 13:36
In Windows 10 is het standaard niet mogelijk om via de F8-toets in de veilige modus op te starten. Met een simpele aanpassing in de Boot Configuration Data kunt u dit weer activeren. Maar er zijn ook nog andere manieren om Windows 10 in de veilige modus op te starten. Via een aanpassing in het register is het...


Lees meer

Maxstar27
Berichten: 6
Lid geworden op: 01 feb 2010, 15:32

Re: Feed to Post

Bericht door Maxstar27 » 13 mar 2020, 11:38

Maar dit zijn maar 256 tekens en 313 inclusief spaties.

Afbeelding

Gebruikersavatar
Ger
Moderator-team
Moderator-team
Berichten: 4856
Lid geworden op: 03 jan 2006, 22:23
Locatie: 192.68.1.100
Contacteer:

Re: Feed to Post

Bericht door Ger » 13 mar 2020, 14:12

Je moet naar de bron kijken. Inclusief HTML voor de link e.d. kom je uit op 503 tekens (verschil komt doordat op een heel woord wordt afgekapt). En dan gaat dat nog eens door de phpBB parser heen, etc.

Zie ook wat er in het beheerderspaneel staat:
Woorden worden niet afgekapt en eventuele HTML-fouten die hierdoor ontstaan worden gerepareerd alvorens de BBcode conversie plaatsvind.

Maxstar27
Berichten: 6
Lid geworden op: 01 feb 2010, 15:32

Re: Feed to Post

Bericht door Maxstar27 » 13 mar 2020, 14:30

Oké, dat maakt het een stuk duidelijker. De enige vraag die dan overblijft is waarom bij het handmatig verwerken van de feed "Lees meer" als link verschijnt, maar bij automatisch verwerken als "Read more".

Gebruikersavatar
Ger
Moderator-team
Moderator-team
Berichten: 4856
Lid geworden op: 03 jan 2006, 22:23
Locatie: 192.68.1.100
Contacteer:

Re: Feed to Post

Bericht door Ger » 13 mar 2020, 16:11

Het enige wat ik kan bedenken is dat de gebruiker PC Web Plus geen nederlands als taal heeft ingesteld. Dat is normaliter hetgene wat leidend is. Als dat niet geladen kan worden treedt het normale phpBB fallback mechanisme in werking (bijvoorbeeld als de taalbestanden niet zijn geladen).

Maxstar27
Berichten: 6
Lid geworden op: 01 feb 2010, 15:32

Re: Feed to Post

Bericht door Maxstar27 » 13 mar 2020, 18:19

Het account "PC Web Plus" heeft Nederlands als standaard taal, dat maakt het ook zo vreemd. Maar over het inladen van taalbestanden gesproken, wellicht heeft dit probleem te maken met een ander probleem dat al langer speelt.

Kan het phpBB fallback mechanisme ook in werking treden bij de "Who Is Online" weergave? Sinds phpBB 3.1.11 werkt (viewonline.php) niet meer correct, zie dit topic als voorbeeld. Bij bots wordt correct aangegeven welk forum deze bekijken, maar bij geregistreerde gebruikers niet. Dan is de forumlocatie altijd forumoverzicht terwijl het account werkelijk een andere locatie bekijkt.

In ProSilver treedt dit probleem niet op, in stijlen die erven van ProSilver wel. Bij het ene thema werkt het dan om het om de nl-ISO in ".../styles/themanaam/theme" te plaatsen. In mijn geval is dat niet zo bij een betaald thema - Milk welke erft van ProSilver.

Ik snap dat jullie daar geen support op geven, maar zou dit dus ook met het phpBB fallback mechanisme te maken kunnen hebben? Bots gebruiken als voorgedefinieerde groep de Engelse taal, net als Feed To Post neem ik aan. Maar Feed To Post is niet thema afhankelijk denk ik dan?

Al met al een vreemd iets, waar ik mijn vinger niet op kan leggen. :roll:

Afbeelding

Gebruikersavatar
Ger
Moderator-team
Moderator-team
Berichten: 4856
Lid geworden op: 03 jan 2006, 22:23
Locatie: 192.68.1.100
Contacteer:

Re: Feed to Post

Bericht door Ger » 13 mar 2020, 19:16

Je kunt toch ook gewoon Engels verwijderen?

Maxstar27
Berichten: 6
Lid geworden op: 01 feb 2010, 15:32

Re: Feed to Post

Bericht door Maxstar27 » 21 mar 2020, 15:55

Het Engelse taalpakket verwijderen is geen optie, want er zijn ook forumleden die geen Nederlands spreken. Op mijn testforum met zowel het NL/ENG taalpakket heb ik dit probleem niet, dus dit zal ook niet de trigger zijn.

Maar er is me wel iets anders opgevallen. Via account PC Web Plus zijn (door de jaren heen) vanaf verschillende IP-adressen berichten geplaatst. En door mods ook berichten uit naam van dit account geplaatst. Nu is in de beheerderlog te zien dat de feed steeds door de accounts met deze IP-adressen wordt verwerkt.

Ook wordt de feed zo nu en dan door het Anonymous-account verwerkt met een IP-adres waaraan geen enkel account is gekoppeld?

Gebruikersavatar
El torro
Berichten: 3087
Lid geworden op: 02 sep 2014, 21:28
Locatie: In het zonnige zuiden
Contacteer:

Re: Feed to Post

Bericht door El torro » 21 mar 2020, 16:28

in phpbb worden meerdere zaken gestart op het moment dat er iemand de site bezoekt, niets om je zorgen over te maken dus.

Plaats reactie