problemen met national flags nieuwste versie

Hulp bij het installeren van of op zoek naar een extensie?
Jeanneke57
Berichten: 105
Lid geworden op: 30 jun 2008, 15:55
Locatie: Breda
Contacteer:

problemen met national flags nieuwste versie

Bericht door Jeanneke57 » 30 mei 2019, 09:16

  • Modificatie & Versie:
    Directe link naar de extensie:
    Adres van je forum: https://www.psp-city.nl/forum
    phpBB versie: 3.2.7
    Heb je onlangs een andere modificatie of stijl geïnstalleerd?

    Wat is het probleem?
Ik heb de nieuwste versie van national flags geïnstalleerd met het nederlandse taalpakket maar ik heb nu opeens een aantal termen op mijn site in het engels, bijv.: Index page , last posts etc.
Hoe krijg ik dat terug in het Nederlands?
Zodra ik de flags deactiveer staat alles weer goed.
Groetjes,
Jeanneke

Jeanneke57
Berichten: 105
Lid geworden op: 30 jun 2008, 15:55
Locatie: Breda
Contacteer:

Re: problemen met national flags nieuwste versie

Bericht door Jeanneke57 » 30 mei 2019, 17:42

Opgelost door een iets oudere versie te installeren.
Groetjes,
Jeanneke

John Leeuwis
Berichten: 161
Lid geworden op: 21 mei 2009, 19:24
Locatie: Nijeveen
Contacteer:

Re: problemen met national flags nieuwste versie

Bericht door John Leeuwis » 19 aug 2019, 18:29

Ik heb hetzeldfe.
Is de nieuwste vertaling ook bij te werken?
Ik heb namelijk ook de voorgaande versie van de NL vertaling teruggezet, cache geleeegd, maar nog steeds hetzelfde probleem.

Gebruikersavatar
Solidjeuh
Berichten: 629
Lid geworden op: 05 okt 2010, 06:28
Locatie: Aalst / Belgie
Contacteer:

Re: problemen met national flags nieuwste versie

Bericht door Solidjeuh » 22 aug 2019, 00:42

Dit is de up-to-date NL versie:
https://github.com/Solidjeuh/National-Flags
Maak jij gebruik van mijn vertalingen?
En je bent er happy mee? Doe dan ook een kleine donatie indien gewenst.
Bezoek ook ~Algemeen Hulp Forum~

John Leeuwis
Berichten: 161
Lid geworden op: 21 mei 2009, 19:24
Locatie: Nijeveen
Contacteer:

Re: problemen met national flags nieuwste versie

Bericht door John Leeuwis » 22 aug 2019, 07:46

Deze versie wederom gedownload, maar het probleem zit toch hierin (of in de extensie zelf).
Alles verwijderd en opnieuw de extensie (inclusief het nl bestand) ge-upload.
Fout blijft hetzelfde.
Het neemt de Engelse taal weer op bijna het gehele forum aan..
Je ziet het meteen op de inlogpagina
www.fordmondeoclub.nl

Deze foutmelding krijg ik ook in beeld als ik een gebruikersprofiel opvraag
[phpBB Debug] PHP Notice: in file [ROOT]/includes/acp/acp_users.php on line 153: Undefined index: ACP_USER_FLAG

Gebruikersavatar
Solidjeuh
Berichten: 629
Lid geworden op: 05 okt 2010, 06:28
Locatie: Aalst / Belgie
Contacteer:

Re: problemen met national flags nieuwste versie

Bericht door Solidjeuh » 22 aug 2019, 16:20

Vreemd, ik heb het net getest op mijn lokaal test forum met deze NL vertaling, en alles werkt perfect. De taal is goed, en geen enkele foutmelding. Al eens geprobeerd om [ROOT]/includes/acp/acp_users.php opnieuw te uploaden vanuit de phpBB download pakket? Volgens mij zit er ergens iets niet goed in dat bestand, of een ander...
Maak jij gebruik van mijn vertalingen?
En je bent er happy mee? Doe dan ook een kleine donatie indien gewenst.
Bezoek ook ~Algemeen Hulp Forum~

John Leeuwis
Berichten: 161
Lid geworden op: 21 mei 2009, 19:24
Locatie: Nijeveen
Contacteer:

Re: problemen met national flags nieuwste versie

Bericht door John Leeuwis » 22 aug 2019, 16:47

GA ik meteen proberen

John Leeuwis
Berichten: 161
Lid geworden op: 21 mei 2009, 19:24
Locatie: Nijeveen
Contacteer:

Re: problemen met national flags nieuwste versie

Bericht door John Leeuwis » 22 aug 2019, 16:50

Helaas geen verschil.
Het blijft zoals het is.
Schakel ik NAtional Flags uit, dan is het probleem opgelost.
Is toch vreemd??

Gebruikersavatar
Ger
Moderator-team
Moderator-team
Berichten: 4835
Lid geworden op: 03 jan 2006, 22:23
Locatie: 192.68.1.100
Contacteer:

Re: problemen met national flags nieuwste versie

Bericht door Ger » 23 aug 2019, 09:54

Kan het zijn dat je in phpBB 3.0 (of 3.1) ook al de national flags had draaien? Lijkt er haast op dat je te maken hebt met een module onder acp_users welke niet in de huidige versie beschikbaar is. De opvraagde vertaling is daardoor ook niet beschikbaar, maar dat is slechts een symptoom en niet het eigenlijke probleem.

Kijk eens in het beheerderspaneel -> tabblad Systeem -> Onder Modulebeheer kies je Beheerderspaneel. Vervolgens kies je voor Gebruikers en groepen -> Gebruikers.

Kun je een screenshot plaatsen van wat je daar ziet?

John Leeuwis
Berichten: 161
Lid geworden op: 21 mei 2009, 19:24
Locatie: Nijeveen
Contacteer:

Re: problemen met national flags nieuwste versie

Bericht door John Leeuwis » 23 aug 2019, 11:27

Ik kan geen bijlage plaatsen.
Met img-img pakt hij de afbeelding niet.

Gebruikersavatar
Ger
Moderator-team
Moderator-team
Berichten: 4835
Lid geworden op: 03 jan 2006, 22:23
Locatie: 192.68.1.100
Contacteer:

Re: problemen met national flags nieuwste versie

Bericht door Ger » 23 aug 2019, 12:08

Kun je dan kijken of je iets ziet in die lijst wat duidt op de national flags extensie? Of anders gewoon overschrijven wat er staat?

Gebruikersavatar
Ger
Moderator-team
Moderator-team
Berichten: 4835
Lid geworden op: 03 jan 2006, 22:23
Locatie: 192.68.1.100
Contacteer:

Re: problemen met national flags nieuwste versie

Bericht door Ger » 23 aug 2019, 18:10

Ik had inloggegevens ontvangen.

Op bovengenoemd locatie in het beheerders paneel stond inderdaad een module die overbodig lijkt, te weten ACP_USER_FLAG. Deze heb ik uitgeschakeld.

@John Leeuwis kun jij bevestigen dat hiermee het probleem verholpen is en zo ja de rechten van mijn gebruiker weer intrekken?

John Leeuwis
Berichten: 161
Lid geworden op: 21 mei 2009, 19:24
Locatie: Nijeveen
Contacteer:

Re: problemen met national flags nieuwste versie

Bericht door John Leeuwis » 23 aug 2019, 20:51

Helaas, probleem niet verholpen.
Niet op pc en ook niet op mijn mobiel (logisch).
Als je wilt inloggen, dan zie je het al in het Engels staan.
Op het portaal, alles Engels.

Gebruikersavatar
Ger
Moderator-team
Moderator-team
Berichten: 4835
Lid geworden op: 03 jan 2006, 22:23
Locatie: 192.68.1.100
Contacteer:

Re: problemen met national flags nieuwste versie

Bericht door Ger » 24 aug 2019, 07:49

Ah ok, ik had me op de foutmelding gefocust die je beschreef, niet op de taal instelling.

Gebruikersavatar
Ger
Moderator-team
Moderator-team
Berichten: 4835
Lid geworden op: 03 jan 2006, 22:23
Locatie: 192.68.1.100
Contacteer:

Re: problemen met national flags nieuwste versie

Bericht door Ger » 25 aug 2019, 08:38

Hebben jullie deze fix al toegepast?
https://www.phpbb.com/customise/db/exte ... 11#p622311

John Leeuwis
Berichten: 161
Lid geworden op: 21 mei 2009, 19:24
Locatie: Nijeveen
Contacteer:

Re: problemen met national flags nieuwste versie

Bericht door John Leeuwis » 25 aug 2019, 09:42

Ger schreef:
25 aug 2019, 08:38
Hebben jullie deze fix al toegepast?
https://www.phpbb.com/customise/db/exte ... 11#p622311
En dit

Code: Selecteer alles

$flag_name = isset($this->user->lang[strtoupper(str_replace(" ", "_", $flags[$flag_id]['flag_name']))]) ? html_entity_decode($this->user->lang[strtoupper(str_replace(" ", "_", $flags[$flag_id]['flag_name']))]) : html_entity_decode($flags[$flag_id]['flag_name']);
zou dan hier moeten staan?
/ext/rmcgirr83/nationalflags/language/nl/common.php?

John Leeuwis
Berichten: 161
Lid geworden op: 21 mei 2009, 19:24
Locatie: Nijeveen
Contacteer:

Re: problemen met national flags nieuwste versie

Bericht door John Leeuwis » 26 aug 2019, 07:49

National Flags maar uitgeschakeld en voila, meteen is de vertaling forumbreed weer correct.

Gebruikersavatar
Ger
Moderator-team
Moderator-team
Berichten: 4835
Lid geworden op: 03 jan 2006, 22:23
Locatie: 192.68.1.100
Contacteer:

Re: problemen met national flags nieuwste versie

Bericht door Ger » 26 aug 2019, 16:12

Nevermind, die fix heeft de extensie auteur zelf al toegepast. Het probleem lijkt te herleiden naar dit issue: https://tracker.phpbb.com/browse/PHPBB3-15315

Volgens die logica zou het probleem als volgt verholpen moeten kunnen worden:
  1. Schakel de extensie uit
  2. Open ./ext/rmcgirr83/nationalflags/event/listener.php
  3. ZOEK

    Code: Selecteer alles

    'core.user_setup'							=> 'user_setup',
  4. VERVANG DOOR

    Code: Selecteer alles

    'core.user_setup_after'							=> 'user_setup',
  5. Sla het bestand op
  6. Schakel de extensie in
Let op: op eigen risico; het is niet mijn extensie en zelf heb ik het issue niet. Tevens werkt dit alleen in phpBB versie 3.1.6 en hoger.

John Leeuwis
Berichten: 161
Lid geworden op: 21 mei 2009, 19:24
Locatie: Nijeveen
Contacteer:

Re: problemen met national flags nieuwste versie

Bericht door John Leeuwis » 26 aug 2019, 17:51

Ga ik vanavond eens proberen.
Ik post de uitkomst wel 👍🏻

John Leeuwis
Berichten: 161
Lid geworden op: 21 mei 2009, 19:24
Locatie: Nijeveen
Contacteer:

Re: problemen met national flags nieuwste versie

Bericht door John Leeuwis » 27 aug 2019, 07:41

Geprobeerd, maar geeft een witte pagina.
500 fout.
URL wordt:
https://www.fordmondeoclub.nl/phpBB3/ad ... ction=list

Plaats reactie