Blanco pagina na registratie

Plaats reactie
John Leeuwis
Berichten: 173
Lid geworden op: 21 mei 2009, 19:24
Locatie: Nijeveen
Contacteer:

Blanco pagina na registratie

Bericht door John Leeuwis » 22 feb 2016, 11:58

  • Adres van je forum: http://johnleeuwis.nl
    Event. modificaties op je forum:Veel
    Wanneer ontstond het probleem?Na upgrade van 3.0.14 naar 3.1.7 pl
    phpBB versie:3.1.7 pl


    Heb je onlangs iets veranderd aan je forum?de upgrade
    Wat is het probleem?
Bij registratie een blanco pagina.
Geeft een 500 foutmelding op de pagina
Debug aangezet (// verwijderd)
Geeft geen foutmelding aan.

In het logboek deze entry gevonden:
Anonymous 80.61.212.191 22 Feb 2016, 11:50 Failed login » Username: john leeuwis

Gebruikersavatar
El torro
Berichten: 3219
Lid geworden op: 02 sep 2014, 21:28
Locatie: In het zonnige zuiden
Contacteer:

Re: Blanco pagina na registratie

Bericht door El torro » 22 feb 2016, 12:17

Kijk eens naar je cookie instellingen, het lijkt daar fout te gaan.

John Leeuwis
Berichten: 173
Lid geworden op: 21 mei 2009, 19:24
Locatie: Nijeveen
Contacteer:

Re: Blanco pagina na registratie

Bericht door John Leeuwis » 24 feb 2016, 12:01

Update naar 3.1.8 probleemoos verlopen.
Registreren blijft echter een blanco pagina geven.
Cookie's staan goed volgens mij.

Cookie-domein: .johnleeuwis.nl
Cookie-naam: phpbb3_forums
Cookie-pad: /
Cookie-beveiliging: uitgeschakeld

Gebruikersavatar
Theriddler
Berichten: 1102
Lid geworden op: 20 apr 2012, 07:47
Contacteer:

Re: Blanco pagina na registratie

Bericht door Theriddler » 24 feb 2016, 12:28

John Leeuwis schreef:Update naar 3.1.8 probleemoos verlopen.
Registreren blijft echter een blanco pagina geven.
Cookie's staan goed volgens mij.

Cookie-domein: .johnleeuwis.nl
Cookie-naam: phpbb3_forums
Cookie-pad: /
Cookie-beveiliging: uitgeschakeld
Probeer eens bij Cookie domein de . voor de url te verwijderen
deze heb je niet echt nodig aangezien je geen www voor de url hebt staan. (http://johnleeuwis.nl)
afgezien van dat zie ik geen problemen in de cookies als ik deze bekijk via web-info, cookies.

Als ik op de betreffende pagina kijk zie ik de registratie pagina voor me.
geen blanco pagina, of is dit pas nadat iemand geregistreerd heeft ?
Theriddler - phpBBservice.nl Teamlid
AfbeeldingSupport Tools | Afbeeldingalgemene-voorwaarden | Afbeelding My Extensions | buy me a beer Afbeelding

John Leeuwis
Berichten: 173
Lid geworden op: 21 mei 2009, 19:24
Locatie: Nijeveen
Contacteer:

Re: Blanco pagina na registratie

Bericht door John Leeuwis » 24 feb 2016, 13:00

Ná registratie ingevuld te hebben.
Dan krijg je een blanco scherm.

Geprobeerd, geen verschil.
Wel cache geleegd.

Gebruikersavatar
Ger
Moderator-team
Moderator-team
Berichten: 4857
Lid geworden op: 03 jan 2006, 22:23
Locatie: 192.68.1.100
Contacteer:

Re: Blanco pagina na registratie

Bericht door Ger » 24 feb 2016, 14:55

Heb je wijzigingen aan je forum aangebracht toevallig?

Zoniet, dan kun je proberen om de originele bestanden van 3.1.8 eens te uploaden naar je forum en de bestaande bestanden hierbij te overschrijven, behoudens het bestand config.php en de mappen /install /images /files.

Maak voor de zekerheid wel eerst even een backup.

John Leeuwis
Berichten: 173
Lid geworden op: 21 mei 2009, 19:24
Locatie: Nijeveen
Contacteer:

Re: Blanco pagina na registratie

Bericht door John Leeuwis » 25 feb 2016, 10:45

Gedaan, zonder succes.
Vreemd hoor.

Heeft dit een betekenis?

Code: Selecteer alles

<body onLoad="javascript:expandCollapse('infoBlockID', true); initGoBack(); navCancelInit(); initMoreInfo('infoBlockID');">
Of is dit de verwijzing naar het weergeven van de 500 foutmelding.

Gebruikersavatar
Ger
Moderator-team
Moderator-team
Berichten: 4857
Lid geworden op: 03 jan 2006, 22:23
Locatie: 192.68.1.100
Contacteer:

Re: Blanco pagina na registratie

Bericht door Ger » 25 feb 2016, 12:15

Waar zie je dat? Als ik gewoon op je forum zit of naar de registratiepagina ga, zie ik dat niet in de broncode terugkomen.
Overigens duidt een witte pagina vrijwel altijd op een PHP en/of MySQL fout, niet op een fout aan de front-end.

Ik zie wel dat je diverse extensies hebt geïnstalleerd. Als je dus in de standaard phpBB-bestanden alles origineel hebt, wordt het tijd om naar de extensies te kijken. Schakel die eens één voor één uit en probeer de registratie vervolgens te doorlopen. Wellicht zit er daar iets niet goed. Als je er op een gegeven moment wel doorheen komt met een specifieke extensie uitgeschakeld, dan zit de fout waarschijnlijk daarin. Je kunt dan eens gaan kijken of het een bekend probleem is bij die extensie en of er misschien een oplossing en/of update van die extensie is.

PS: ik heb net een testregistratie gedaan, ger_phpbb_nl of iets in die richting. Als dat account dus in je gebruikerslijst staat, kun je die verwijderen.

John Leeuwis
Berichten: 173
Lid geworden op: 21 mei 2009, 19:24
Locatie: Nijeveen
Contacteer:

Re: Blanco pagina na registratie

Bericht door John Leeuwis » 25 feb 2016, 12:35

Ger schreef:Waar zie je dat? Als ik gewoon op je forum zit of naar de registratiepagina ga, zie ik dat niet in de broncode terugkomen.
In IE F12
Ger schreef:PS: ik heb net een testregistratie gedaan, ger_phpbb_nl of iets in die richting. Als dat account dus in je gebruikerslijst staat, kun je die verwijderen.
Vast geen bevestigingsmail gekregen denk ik?

Zal eens met de extensies aan de gang gaan.

Gebruikersavatar
Ger
Moderator-team
Moderator-team
Berichten: 4857
Lid geworden op: 03 jan 2006, 22:23
Locatie: 192.68.1.100
Contacteer:

Re: Blanco pagina na registratie

Bericht door Ger » 25 feb 2016, 13:16

Ik bedoelde op welke pagina, maar heb het inmiddels ontdekt.
Het is een ding van Internet Explorer, gebruikt om de foutpagina weer te geven. Niet van belang voor jouw probleem.

Bevestigingsmail heb ik niet gekregen, maar heb een @example.com emailadres gebruikt, dus niet-bestaand.

frostbytes
Berichten: 14
Lid geworden op: 01 mar 2016, 09:18

Re: Blanco pagina na registratie

Bericht door frostbytes » 05 mar 2016, 09:53

Heb je dit probleem nog steeds? Want ik heb het met gebruik van Chrome en andere IO's.
Ben benieuwd of dit echt een 3.1 issue is of iets anders..


Hoor graag van je!

Gebruikersavatar
Christan
Berichten: 9
Lid geworden op: 28 dec 2015, 19:25
Locatie: Escharen
Contacteer:

Re: Blanco pagina na registratie

Bericht door Christan » 08 mar 2016, 10:20

Ik heb ongeveer de zelfde uitdaging in 3.1.8. Nieuwe gebruikers worden aangemaakt via de extensie adduser-1.0.2 van phpbbmodders. Zelf registreren staat uit, omdat het een besloten forum is / moet zijn. Na het aanmaken van een gebruiker verschijnt er een wit scherm en er wordt geen e-mail verzonden naar de nieuwe gebruiker. Deze is echter wel aangemaakt en actief, want er kan wel ingelogd worden.
Uitschakelen van de extensie t.b.v. foutopsporing heeft m.i. weinig zin, want dit is de enige extensie die is geïnstalleerd.
The Band Elwood, THE BAND!
Jesus H. Tapdancing Christ, I have seen the light!

Gebruikersavatar
Theriddler
Berichten: 1102
Lid geworden op: 20 apr 2012, 07:47
Contacteer:

Re: Blanco pagina na registratie

Bericht door Theriddler » 08 mar 2016, 10:42

Christan schreef:Ik heb ongeveer de zelfde uitdaging in 3.1.8...
Hallo Christan, Het beste is om even een nieuw/eigen onderwerp aan te maken in 3.1 support met het probleem, zodat het hier overzichtelijk blijft voor TS.
Theriddler - phpBBservice.nl Teamlid
AfbeeldingSupport Tools | Afbeeldingalgemene-voorwaarden | Afbeelding My Extensions | buy me a beer Afbeelding

Gebruikersavatar
Theriddler
Berichten: 1102
Lid geworden op: 20 apr 2012, 07:47
Contacteer:

Re: Blanco pagina na registratie

Bericht door Theriddler » 08 mar 2016, 10:49

@John

ik zie diverse fouten in de debug console met firebug op de registratie pagina:

Code: Selecteer alles

"NetworkError: 404 Not Found - http://www.fordmondeoclub.nl/phpBB3qaptcha/jquery/jquery.min.js"
jquery.min.js
"NetworkError: 404 Not Found - http://www.fordmondeoclub.nl/phpBB3qaptcha/jquery/jquery.ui.touch.js"
jquery....ouch.js
"NetworkError: 404 Not Found - http://www.fordmondeoclub.nl/phpBB3qaptcha/jquery/jquery-ui.js"
jquery-ui.js
"NetworkError: 404 Not Found - http://www.fordmondeoclub.nl/phpBB3qaptcha/jquery/QapTcha.jquery.js"
QapTcha.jquery.js
"NetworkError: 404 Not Found - http://www.fordmondeoclub.nl/phpBB3qaptcha/jquery/jquery.min.js"
jquery.min.js
"NetworkError: 404 Not Found - http://www.fordmondeoclub.nl/phpBB3qaptcha/jquery/jquery-ui.js"
jquery-ui.js
"NetworkError: 404 Not Found - http://www.fordmondeoclub.nl/phpBB3qaptcha/jquery/jquery.ui.touch.js"
jquery....ouch.js
"NetworkError: 404 Not Found - http://www.fordmondeoclub.nl/phpBB3qaptcha/jquery/QapTcha.jquery.js"
QapTcha.jquery.js
TypeError: $(...) is null
	

$("head").append("<link />");

	
ucp.php...egister (regel 409, kol 1)
TypeError: $(...).ready is not a function
	

$(document).ready(function(){

	
ucp.php...egister (regel 421, kol 1)
Theriddler - phpBBservice.nl Teamlid
AfbeeldingSupport Tools | Afbeeldingalgemene-voorwaarden | Afbeelding My Extensions | buy me a beer Afbeelding

TWEagle
Berichten: 782
Lid geworden op: 18 nov 2005, 19:45
Locatie: Peer
Contacteer:

Re: Blanco pagina na registratie

Bericht door TWEagle » 09 mar 2016, 19:27

moet dat niet captcha zijn? ipv qaptcha??
Afbeelding
To see or to hear

Gebruikersavatar
Christan
Berichten: 9
Lid geworden op: 28 dec 2015, 19:25
Locatie: Escharen
Contacteer:

Re: Blanco pagina na registratie

Bericht door Christan » 11 mar 2016, 15:29

Met het risico dat ik tegen regels in me op de verkeerde plaats ergens mee bemoei, bij voorbaat sorry.
Er is een geüpdate versie van de extensie Add User en die loste voor mij het probleem op.
https://github.com/phpbbmodders/phpbb-3.1-ext-adduser
The Band Elwood, THE BAND!
Jesus H. Tapdancing Christ, I have seen the light!

Plaats reactie